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PowerPoint Presentations on the Web 

Sample PowerPoint Presentations from Davis School District 

 Sample PowerPoint presentations are available on the web from Davis School District. 

 Open the Internet. 

 In the address line, enter http://www.davis.k12.ut.us/district/etc/powerpoint.html 

 Press the Enter key. 

Finding Presentations on the Web through Google 

 Open the Internet and go to http://www.google.com 

 Click on Advanced Search.  

 Enter words or phrases to describe desired results. 

 On the File Format line, click on the down arrow 

and choose Microsoft PowerPoint (.ppt). 

 Click on the Google Search button at the top. 

Playing a PowerPoint Presentation on the Web 

 Navigate to the PowerPoint presentation. 

 Click on the link. 

 Click on the Open button. 

 The presentation opens in PowerPoint 2007 

Saving a PowerPoint Presentation 

 Navigate to the PowerPoint presentation. 

 Click on the link. 

 Click on the Save button. 

 Navigate to the location where the presentation is to be saved. 

 Notice the name of the presentation and change if desired. 

 Click on the Save button. 

Starting PowerPoint 

 On the Start button, click on All Programs  Microsoft Office  Microsoft PowerPoint. 

Opening a Presentation 

 Click on the Microsoft Office Button and then click on Open. 

 Navigate to the location of the PowerPoint file. 

 Choose the name of the file and click on the Open button. 

  

http://www.davis.k12.ut.us/district/etc/powerpoint.html
http://www.google.com/
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Microsoft Office Button 

 The Microsoft Office Button is in the top left corner of the 

window and provides access to open, save, and print documents. 

 Click on the Microsoft Office Button and then click on the 

desired option. 

 Menu options with an arrow have additional choices available in the area to the right. 

 The PowerPoint Options button at the bottom of the window allows the user to make 

adjustments to PowerPoint such as color scheme, display options, AutoCorrect options, 

and spelling. 

Quick Access Toolbar 

 The Quick Access Toolbar is just to the right of the Microsoft Office Button. 

 When the cursor is over a button, the name of the button is displayed. 

 The options available when Microsoft Office 2007 is first installed include Save, Undo, 
and Redo. 

Customizing the Quick Access Toolbar 

 To add an item, click on the Customize Quick Access Toolbar drop down arrow at the 

end of the Quick Access Toolbar and click on the desired item. 

 Options with a check mark in front of them are displayed on the Quick Access 

Toolbar. 

 To remove a button, click on the Customize Quick Access Toolbar drop down arrow 

at the end of the Quick Access Toolbar and click on the desired item. (This removes 

the checkmark from in front of the item.) 

 To add a command button from the Ribbon, right click on the desired command 

button and choose Add to Quick Access Toolbar. 

 To remove a command button that has been added to the Quick Access Toolbar, right 

click on the button on the Quick Access Toolbar and choose Remove from Quick 

Access Toolbar.  

Changing the Order of the Buttons on the Quick Access Toolbar 

 Click on the Customize Quick Access Toolbar drop down arrow at the end of the Quick Access 

Toolbar and choose More Commands…. 

 In the column on the right below Customize Quick Access Toolbar, click on the item to be 

moved. 

 To move the item up, click on the up arrow at the right. 

 To move the item down, click on the down arrow at the right. 

 Click on OK. 

Position of the Quick Access Toolbar 

 The Quick Access Toolbar is usually located to the right of the Microsoft Office Button.  

 To place the Quick Access Toolbar below the Ribbon, click on the Customize Quick Access Toolbar 

drop down arrow and choose Show Below the Ribbon. 

 To place the Quick Access Toolbar back next to the Microsoft Office Button, click on the Customize 

Quick Access Toolbar drop down arrow and choose Show Above the Ribbon. 
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The Ribbon 

 
 The Ribbon runs across the top of the window. 

 The Ribbon consists of 3 types of items. 

o Tabs – This is the main level and includes Home, Insert, Page Layout, etc. 

o Groups – Each tab has several groups that show related items together. 

o Commands – A command is a button in a group or an item in a list. 

 Some tabs are only available when a particular item is selected. For example, the Picture Tools tab is only 

shown when a picture is clicked on. 

Using the Ribbon 

 Click on the desired tab. 

 The commands under each tab are grouped. The name of the group is at the bottom. 

 Some groups have a Dialog Box Launcher button which opens the dialog box with more 

commands. 

Minimizing/Restoring the Ribbon 

 To minimize the Ribbon, click on the Customize Quick Access Toolbar drop down arrow and choose 

Minimize the Ribbon (a checkmark is now displayed in front of Minimize the Ribbon)  

o OR double click on the currently selected tab on the Ribbon. 

 To display the Ribbon, click on the Customize Quick Access Toolbar drop down arrow and choose 

Minimize the Ribbon (the checkmark in front of Minimize the Ribbon is removed.)  

o OR double click on the currently selected tab on the Ribbon. 

Keyboard Shortcuts 

 Press the Alt key on the keyboard to display the keystrokes for the tabs. 

 Press the desired key such as H for the Home tab. 

 Continue pressing the indicated keys and/or down arrow to make the desired choices. 

 To remove the keystroke markers from the screen, press the Alt key. 

Help 

 Click on the Microsoft Office PowerPoint Help button in the top 

right corner. 

 Type the desired word in the search box and then press the Enter key. 

 Choose the desired topic from the ones displayed. 

 To research another topic, enter the desired word in the search box 

and then press the Enter key. 

 Note – An active Internet connection will find more results. 
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Outline and Slides Pane 

 On the left side is the Outline and Slides Pane. 

 The Outline tab displays an outline of the presentation.  

o Text can be entered directly into the outline. 

 The Slide tab shows thumbnails of each slide. 

o Click on the desired slide to display it in 

the Slide Pane. 

 Click on the X at the top right corner of the pane to 

close it. 

 To bring the pane back, on the Ribbon, click on 

View tab and in the Presentations Views group, 

click on the Normal button. 

Slide Pane 

 In the middle of the screen is the Slide Pane. 

 This is the working area most people use. 

Notes Pane 

 At the bottom is the Notes Pane. 

 Notes for the presenter can be entered in the Notes Pane.   

 Notes are associated with the slide that is showing. 

 Note – The notes do not show up when viewing the slide show. There is an option to print the notes. 

Changing the Size of the Panes 

 Place the cursor over the line that divides the panes. (The cursor changes to a two-headed arrow.) 

 Click and drag to the desired size. 

Zooming in on the Slide in Normal View 

 The Zoom bar is in the bottom right corner of the window. 

 Click on the Zoom slider and drag it until the slide is the desired size. 

 To make full use of the size of the Slide Pane, click on the Fit slide to current window button to the right 

of the Zoom slider. 

Changing the View 

 The view of the window can be changed with buttons at the bottom right of the Outline and Slides Pane 

 OR on the Ribbon, click on the View tab and in the Presentation Views group, click on the desired view. 

Ribbon Button Button Name Description 

 
 Normal View Click on this button to see the three panes. 

   Slide Sorter View 
Click on this button to see thumbnails of the slides.  

Double click on a slide to open it in the Slide Pane. 

 
 Notes Page 

Click on this button to see the presentation with 

notes for each slide. 

 
 Slide Show View 

Click on this button to play the show starting with 

the slide that is currently selected. 
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Slide Sorter View 

 To change the order of the slides, click and drag a slide to the new location 

 OR Cut and Paste: 

o Right click on the slide to be moved and choose Cut. 

o Right click on the slide at the desired location and choose Paste. 

 The new slide will be pasted after the selected slide. 

 To change the size of the thumbnails, click on the slider of the Zoom bar and drag it to adjust the 

thumbnails to the desired size. 

Viewing the Slide Show in Play Mode 

 On the Ribbon, click on the Slide Show tab and in the Start Slide Show group 

click on the From Beginning button or the From Current Slide button. (Press 

F5 to play the slide show from the beginning.) 

 OR to play the slide show from the current slide, click on the Slide Show button 

located at the bottom right of the window. 

Tips and Tricks - Playing the Slide Show 

 

Keyboard Specials 

Action Keystroke Action Keystroke 

Previous Slide Left Arrow key or 

Page Up key 

Next Slide Right Arrow key, Spacebar 

key, Page Down key, or Enter 

Go to the first slide Home key Go to the last slide End key 

Stop the slide show Esc key   

Converting from Older Versions 

 Microsoft Office 2007 can open documents created in all previous versions of PowerPoint. Previous 

versions will be opened in compatibility mode. (You will know if a document has been opened in 

compatibility mode because it will say “compatibility mode” next to the name of the file on the title bar.) 

 Documents that have been opened in compatibility mode may not have the same features on the Ribbon as 

documents created in or converted to the Microsoft Office 2007 version, i.e. instead of SmartArt Graphics, 

it may be Design Gallery objects. 

 Documents created in previous versions of Microsoft Office can be converted to the Microsoft Office 2007 

version. An advantage for converting documents to the newest version is that it will give you access to all 

the new features.  

Converting from Older Versions 

 To convert an open document:  

o Click on the Microsoft Office Button and choose 

Convert. 

o Click on OK. 
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Using the Mouse during a Presentation 

 Right clicking on the slide brings up slide show options. 

Go to Slide 

 You can go directly to a particular slide in the presentation. 

 Right click on the slide. 

 Click on Go to Slide  and choose the desired slide from the list.  

Black or White Screen 

 The presentation  can be paused by bring up a black or a white screen. 

 Right click on the slide. 

 Click on Screen  and choose Black Screen or White Screen.  

 To return to the presentation, right click and click on Screen  Unblack 

Screen  or Screen  Unwhite Screen. 

Annotations 

 Annotations (notes) can be made on a slide. 

 Right click on the slide. 

 To write with a fine line, click on Pointer Options  Ballpoint Pen.  

 To write with a bold line, click on Pointer Options  Felt Tip Pen.  

 To highlight text, click on Pointer Options  Highlighter.  

 Make the desired annotations. 

 To return to normal, right click and click on Pointer Options  Arrow. 

 When the presentation is closed, click on the Keep button to keep the 

annotations or click on the Discard button to remove them. 

Starting a Blank Presentation 

 Starting PowerPoint opens a new presentation OR 

 Click on the Microsoft Office Button and then click on New. 

 In the Templates pane, click on Blank and Recent. 

 In the Blank and Recent pane, click on Blank Presentation. 

 Click on the Create button. 

Applying and Customizing a Theme 

 On the Ribbon, click on the Design tab.  

 In the Themes group, click on the More button located to the far right of the thumbnails. 

 Click on the desired theme. 

o Note – Holding the cursor over a theme without clicking displays the slide with the theme. This 

also applies to each of the choices mentioned below. 

 In the Background group, click on the Background Styles button and choose the desired background. 

 In the Themes group, click on the Colors button and choose the desired color scheme. 

 In the Themes group, click on the Fonts button and choose the desired font theme. 

 In the Themes group, click on the Effects button and choose the desired effect. 
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Applying a Theme to Selected Slides 

 Click on the slide the theme is to be applied to. 

 To select more than one slide, hold down the Control key and click on the additional slides. 

 Click on the Design tab. 

 In the Themes group, right click on the desired theme and choose Apply to Selected Slides. 

Adding More Slides 

 Click on the slide thumbnail where the new slide should go. 
o The new slide will be inserted after the selected slide. 

 On the Ribbon, click on the Home tab. 

 In the Slides group, click on the down arrow of the New Slide button and click on the desired layout for the 

new slide. 

Changing the Layout of a Slide 

 Click on the slide thumbnail to be changed. 

 On the Ribbon, click on the Home tab. 

 In the Slides group, click on the Layout button and choose the desired layout. 

Entering Text 

Entering a Title 

 Click on the title/subtitle field on the slide. 

 Enter the text. 

 Click outside of the text field when finished. 

Entering Bullets 

 See Bulleted and Numbered Lists on page 11. 

Cutting and Pasting Text 

 Select the text to be moved. 

 Press Ctrl X  

 OR on the Ribbon, click on the Home tab. 

o In the Clipboard group, click on the Cut button. 

 Click where the selected text is to be moved.  

 Press Ctrl V 

 OR on the Ribbon, click on the Home tab. 
o In the Clipboard group, click on the Paste button. 

Copying and Pasting Text 

 Select the text to be copied. 

 Press Ctrl C  

 OR on the Ribbon, click on the Home tab. 
o In the Clipboard group, click on the Copy button. 

 Click where the selected text is to be copied.  

 Press Ctrl V 

 OR on the Ribbon, click on the Home tab.  

o In the Clipboard group, click on the Paste button. 
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Spell Check 

Right Click Correct 

 Right click on the word in question. (The word is marked with red underscore.) 

 Select from the words at the top of the box   

 OR on the Ribbon, click on the Review tab. 

o Click on Spelling and use the Spell Checker as noted below. 

Using the Spell Check 

 On the Ribbon, click on the Review tab. 

 In the Proofing group, click on the Spelling button.  

 Click on the Ignore button to leave the spelling of a word as 

it is. 

 To change the spelling of a word, choose the correct spelling 

from the list of Suggestions and click on the Change button. 

 Click on the Close button when finished. 

Saving the Slide Show 

 Click on the Microsoft Office Button and then click on the Save As... button. 

 Enter a title for the slide show. 

 Be sure to notice where you are saving the slide show. 

 Click on the Save button. 

Saving to a Previous Version 

 Files created with PowerPoint 2007 can be opened and worked on in the older versions, but a plugin is 

required. 

 Click on the Microsoft Office Button and then click on Save As. 

 Check the name of the slide show and make changes as needed. 

 In the Save as type box, click on the down arrow and choose PowerPoint 97-2003 Presentation. 

 Click on the Save button. 

Text Boxes 

Creating a Text Box 

 On the Ribbon, click on the Insert tab. 

 In the Text group, click on the Text Box button. 

 Click and drag on the slide to create the text box. 

 Note – A text box cannot be created within another text box. 

Moving a Text Box 

 Click in the text box. 

 Move the cursor to the edge of the box. 

 Note - The cursor changes to a four-headed arrow. 

 Click and drag the box to the desired location. 
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Resizing a Text Box 

 Click in the text box. 

 Move the cursor to a corner of the box.  (The box at the corner is called a handle.) 

 Note - The cursor changes to a two-headed arrow. 

 Click and drag to change the size of the box. 

Deleting a Text Box 

 Click in the text box. 

 Click on the border of the text box. 

 Press the Delete key on the keyboard. 

Text Appearance 

Changing the Font and Font Attributes 

 Highlight the text. 

 On the Ribbon, click on the Home tab. 

 In the Font group, choose the desired font, font style, font 

size, or font color. 

o Note – The font size can also be changed by using 

the Increase Font Size and the 

Decrease Font Size buttons. 

 OR on the Ribbon, click on the Home tab. 

 In the Font group, click on the Dialog Box Launcher 

button located in the bottom right corner.  
o Choose the desired font, font style, font size, or 

font color. 

o Click on OK. 

 Note - Some resizing of the font takes place automatically 

as more text is added to a slide. 

Changing Text Justification 

 Highlight the text. 

 On the Ribbon, click on the Home tab. 

 In the Paragraph group, choose the desired alignment. 

Mini toolbar 

 The Mini toolbar is a semi-transparent toolbar which appears when text is selected. 

 Highlight text to be formatted. 

 Use the buttons on the Mini toolbar to make the desired changes to the text. 

 If the Mini toolbar has disappeared, right click on the highlighted text to 

bring up the Mini toolbar. 
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Bulleted and Numbered Lists 

Entering Bullets 

 Click on the bullet text field. 

 Type the desired text. 

 Press the Enter key to move to the next bullet. 

 Press the Tab key to create sub-bullets 

 OR on the Ribbon, click on the Home tab. 

o In the Paragraph group, click on the Increase Indent button. 

 To decrease the indentation, hold down the Shift key and press the Tab key  

 OR on the Ribbon, click on the Home tab. 

o In the Paragraph group, click on the Decrease Indent button. 

Turning off Bullets or Numbering 

 Click in the line of text that is bulleted or numbered. 

 On the Ribbon, click on the Home tab. 

 In the Paragraph group, click on the Bullets button to turn off bullets. 

 In the Paragraph group, click on the Numbering button to turn off numbering. 

Switching between Bullets and Numbering 

 Highlight the desired text or click in the line of text. 

 On the Ribbon, click on the Home tab. 

 In the Paragraph group, click on the Numbering button to change to numbering. 

 In the Paragraph group, click on the Bullets button to change to bullets. 

Modifying Bulleted or Numbered Lists 

 Highlight the desired text.  

 On the Ribbon, click on the Home tab. 

 In the Paragraph group, click on the Bullets down arrow and then 

click on Bullets and Numbering….  

 For bulleted text: 

o Click on the Bulleted tab. 
o Click on the desired type of bullets. 

o Click on the Customize button for more options. 

 Note - Choosing a different font will give other 

choices for bullets, (i.e. Wingdings, etc.) 

 Click on OK. 

o Adjust the Size as desired. 

o Change the color of the bullet as desired. 

o Click on OK. 

 For numbered text: 

o Click on the Numbered tab. 

o Choose the desired type of numbering. 
o Adjust the Size as desired. 

o Change the color of the numbering as desired. 

o Click on OK. 

  



 

Page 12 

Technology Integration Center 

Davis School District, Farmington, Utah  84025 Revised 3/19/2009 

Changing Line Spacing 

 Highlight the text to be changed. 

 On the Ribbon, click on the Home tab. 

 In the Paragraph group, click on the Line Spacing button 

and change the line spacing as desired. 

 OR on the Ribbon, click on the Home tab. 

o Click on the Line Spacing button and choose Line 

Spacing Options. 

 In each of the sections, make the desired adjustments. 

 Note - The Before paragraph and After paragraph 

choices in the Spacing section separate bulleted items and 

paragraphs. 

 Click on OK. 

Changing the Slide Master 

 Making changes to the Slide Master affects the entire presentation. 

 On the Ribbon, click on the View tab. 

 In the Presentation Views group, click on the Slide Master button. 

 The Slide Pane on the left displays the types of slides used in the 

presentation. 

 Holding the cursor over a slide type displays the name of the layout and the number of 

slides in the presentation using that layout. 

 Click on the desired Slide Master. 

 Click on the parts of the slide that are to be changed and make the changes. 

o Changes might include the font style, font size, bullet symbols and colors, etc. 

 On the Ribbon, click on the Slide Mater tab. 

 In the Close group, click on the Close Master View button. 

 Note – Changes made before editing the Master Slide will not be affected. 

Modifying the Presentation 

Arranging the Slides 

 Slide Sorter View 
o Click on the Slide Sorter button at the bottom right of the window 

o OR on the Ribbon, click on the View tab, and in the Presentation Views group, 

click on the Slide Sorter button.  
o Click on the slide to be moved and drag it to the new location. 

o Note - As the slide is dragged to the new location, a vertical bar will show where the slide will go 

when the mouse button is released.  

 Normal View 

o Click on the Normal button at the bottom right of the window 

o OR on the Ribbon, click on the View tab, and in the Presentation Views group, 

click on the Normal button.  
o In the Slide Pane, click on the slide to be moved and drag it to the new location. 

 Cut and Paste 
o Right click on the slide to be moved and choose Cut. 

o Right click on the slide at the desired location and choose Paste. 

 The new slide will be pasted after the selected slide. 
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Deleting a Slide 

 Slide Sorter View 
o Click on the Slide Sorter button at the bottom right of the window 

o OR on the Ribbon, click on the View tab, and in the Presentation Views group, 

click on the Slide Sorter button.  
o Click on the slide to be deleted and press the Delete key. 

 Normal View 

o Click on the Normal button at the bottom right of the window 

o OR on the Ribbon, click on the View tab, and in the Presentation Views group, 

click on the Normal button.  
o In the Slide Pane, click on the slide to be deleted and press the Delete key. 

Adding Notes to a Slide 

 Click on the slide thumbnail to which the notes are to be added. 

 Click in the Notes Pane and add the desired information. 

Pictures 

Inserting a Picture from Clip Art 

 For best search results, an Internet connection is required. 

 On the Ribbon, click on the Insert tab. 

 In the Illustrations group, click on the Clip Art button. 

 In the Clip Art pane, type a word in the Search for box. 

 Click on the Go button.  

 Scroll through the list to find the desired clipart. 

o The small world icon in the bottom left hand corner of the thumbnail 
indicates that the picture is located on the Internet at Microsoft’s 

website. 

o The yellow star icon in the bottom right hand corner of the thumbnail 

indicates the picture is animated. 

 To view the animation, right-click on the thumbnail and choose 

Preview/Properties. 

 Click on the desired picture to add it to the slide. 

 Searching for a Different Picture 
o Enter a new word in the Search text: box. 

o Click on the Go button. 

Inserting a Picture from Files 

 On the Ribbon, click on the Insert tab. 

 In the Illustrations group, click on the Picture button. 

 Navigate to the location of the picture, i.e. the My Pictures folder. 

 Click on the desired picture. 

 Click on the Insert button. 

Copying Pictures from the Internet 

 Find the picture on the Internet. 

 Right click on the picture and choose Copy. 

 Click on the slide thumbnail where the picture will be placed. 

 Right click on the slide and choose Paste. 
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Saving Pictures from the Internet 

 Find the picture on the Internet. 

 For a list of picture sites, go to http://www.davis.k12.ut.us/district/etc/cathy/clipart.html  

 Note - Be sure to read the Terms of Use on the site with the picture.  Don’t use it without permission. 

 Right click on the picture and choose Save Picture As.... 

 Navigate to where you are going to save the picture, i.e. the My Pictures folder. 

 Change the name of the picture if desired. 

 Click on Save. 

Deleting a Picture 

 Click on the picture. 

 Press the Delete key. 

Moving a Picture 

 Click in the middle of the picture and drag it to the desired location. 

 Note – The cursor changes to a four-headed arrow. 

Resizing a Picture 

 Click on the picture to select it. 

 Move the cursor to a handle (circle) at the corner. 

 Note – The cursor changes to a double-headed arrow. 

 Click and drag towards the center of the picture to make it smaller OR away from the picture to make it 

larger. 

Rotating a Picture 

 Double click on the picture.  

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Arrange group, click on the Rotate button and choose the desired rotation. 

 OR click on the green dot above the picture and drag the picture to the desired angle. 

Adjusting the Brightness of a Picture 

 Double click on the picture.  

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Adjust group, click on the Brightness button and choose the desired 

brightness. 

 Note – Holding the cursor over a choice without clicking displays the picture with that choice. 

Adjusting the Contrast of a Picture 

 Double click on the picture.  

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Adjust group, click on the Contrast button and choose the desired contrast. 

 Note – Holding the cursor over a choice without clicking displays the picture with that choice. 

  

http://www.davis.k12.ut.us/district/etc/cathy/clipart.html
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Recoloring a Picture 

 Double click on the picture.  

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Adjust group, click on the Recolor button and choose the desired brightness. 

 Note – Holding the cursor over a choice without clicking displays the picture with that choice. 

Setting a Transparent Color 

 Double click on the picture.  

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Adjust group, click on the Recolor button and choose Set Transparent Color. 

 In the picture, click on the color that is to become transparent. 

Picture Styles 

 Styles can be quickly applied to pictures. 

 Double click on the desired picture. 

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Picture Styles group, click on the More button (bottom down arrow) of the 

styles window.   

 Click on the desired style. 

 Note – Holding the cursor over a style without clicking displays the picture with that style. 

Changing the Picture Shape 

 Double click on the desired picture. 

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Picture Styles group, click on the Picture Shape button and choose the desired shape.   

 Note – Holding the cursor over a shape without clicking displays the picture with that shape. 

Changing the Picture Border 

 Double click on the desired shape or object. 

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Picture Styles group, click on the Picture Border button and choose the desired border.   

 Note – Holding the cursor over a border without clicking displays the picture with that border. 

Changing the Picture Effects 

 Double click on the desired shape or object. 

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Picture Styles group, click on the Picture Effects button and choose the desired effect.   

 Note – Holding the cursor over an effect without clicking displays the picture with that effect. 

Changing the Order of Layered Pictures 

 Right click on the picture and choose Bring to Front  or Send to Back  and the desired option. 

o Bring to Front puts the picture on top of all other pictures. 

o Send to Back puts the picture behind all other pictures. 

o Bring Forward puts the picture above another picture. 
o Send Backward puts the picture behind another picture. 
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Compressing Pictures 

 Note - Compressing pictures reduces the file size of the presentation, making 

it more manageable when moving it, sending it by email, etc.  

 Double click on a picture.  

 The Format tab of Picture Tools comes up on the Ribbon. 

 In the Adjust group, click on the Compress Pictures button. 

 If only the selected picture(s) are to be compressed, click in the box to select 

Apply to selected pictures only. 

 Click on the Options button. 

 In the Compression options section, make the desired choices. 

 In the Target output section, choose Screen or E-mail. 

 Click on OK. 

 Click on OK. 

Animating an Object (Text or Pictures) 

 Click on the object. 

 On the Ribbon, click on the Animations tab. 

 In the Animations group, click on the Custom Animation button. 

 Click on the Add Effect button in the Custom Animation pane. 

 Choose Entrance, Emphasis, or Exit. 

 Choose from the available animations in the list. 

 (Optional) Decide if the animation should happen on a mouse click or be 

automatic by clicking on the Start down arrow. 

 (Optional) Decide on the direction the action will go by clicking on the 

Direction: down arrow. 

 (Optional) Decide on the speed of the action by clicking on the Speed down 

arrow. 

 Note – A preview of the animation displays each time a choice is made. 

Changing the Animation 

 Click on the object. 

 Click on the corresponding number of the object in the animation list. 

 Click on the Change button and choose a different animation. 

Removing the Animation 

 Click on the object. 

 Click on the corresponding number of the object in the animation list. 

 Click on the Remove button in the Custom Animation pane to remove the previous choice 

Adding a Delay to an Automatic Animation 

 Click on the object. 

 Click on the down arrow next to the corresponding number of the 

object in the animation list. 

 Click on Timing. 

 Change the Delay to the desired number of seconds.  

 Click OK. 
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Adding Multiple Animations to the Same Object 

 Click on the object. 

 Click on the Add Effect button in the Custom Animation pane. 

 Choose Entrance, Emphasis, or Exit. 

 Choose from the available animations in the list. 

Changing the Order Objects Play 

 If the Custom Animations screen is not showing: 
o On the Ribbon, click on the Animations tab. 

o In the Animations group, click on the Custom Animation button. 

 Look at the list in the Custom Animations pane showing the order in which 

objects play. 

 Click on the object on the slide to be changed. (The animation in the list is 

highlighted.) 

 Click and drag the animation in the list to the desired playing position. 

Slide Transitions 

 Click on the desired slide. 

 On the Ribbon, click on the Animations tab. 

 In the Transition to This Slide group, hold the cursor over a transition without clicking to display the slide 
with that transition. 

 Use the up and down arrows on the right side of 

the Slide Transitions window to scroll through 

the choices. 

 Click on the desired transition. 

 Note – The question mark at the bottom of the list is for random transitions. 

 Adjust the speed of the transition by clicking on 

the Transition Speed down arrow and making the 

desired choice. 

 Add a sound by clicking on the Transition Sound 

down arrow and making the desired choice. 

 In the Advance slide section, choose either On Mouse Click, or set a time for the automatic advance of the 

slide. 

 To apply this transition to all of the slides in the presentation, click on the Apply to All button. 

Rehearse Timings 

 Note – Rehearse timings controls the pacing of the self-running 

show. 

 On the Ribbon, click on the Slide Show tab. 

 In the Set Up group, click on the Rehearse Timings button. 

 Click through the show at the desired pace. 

 Notice the timer in the upper left corner of the window which has controls for pause, etc. 

 At the end of the slideshow a message will appear asking if you want to keep the new slide timings. Click 
on Yes to keep the timings OR No to try again.  
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Self-Running Show 

  Note – To have a self-running slide show, the slide transitions 

must be set to Automatically after with a desired length of time. 

 On the Ribbon, click on the Slide Show button. 

 In the Set Up group, click on the Set 

Up Slide Show button. 

 In the Show Options section, check the 

box to Loop continuously until “Esc”. 

 In the Advance slides section, choose 

Using timings, if present. 

 Click on OK. 

Sounds 

Adding an Automatic Sound to an Animated Object 

 If the Custom Animations screen is not showing: 

o On the Ribbon, click on the Animations tab. 

o In the Animations group, click on the Custom Animation 

button. 

 Click on the animated object to which the sound is to be attached. 

 In the Custom Animation pane, click on the down arrow next to the 

animated object and choose Effect Options. 

 Click on the Effect tab.  

 In the Enhancements section, next to Sound, click on the down 

arrow and choose the desired sound. 

 Click OK. 

Adding a Clickable Sound to an Object 

 Click on the animated object to which the sound is to be attached. 

 On the Ribbon, click on the Insert tab. 

 In the Links group, click on the Action button. 

 Click on the Mouse Click tab. 

 Check the box in front of Play sound. 

 Click on the down arrow in the box and choose the desired sound. 

 OR choose Other Sound… at the bottom of the list and navigate to 

the location of the sound. 

 Click OK. 

 Note – To hear the sound when playing the slide show, click on the 

object with the sound attached. 

Adding a Sound to a Slide Transition 

 Go to the slide that is to have the sound. 

 On the Ribbon, click on the Animations tab. 

 In the Transition to This Slide group, click on the Transition Sound down arrow and make the desired 

choice. 

 Note – To hear the sound, hold the mouse over the sound in the list. 
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Printing 

 Click on the Microsoft Office Button and choose Print  Print Preview. 

 In the Page Setup group, click on the Print What: button and choose the desired 

option. 

o Slides – Prints 1 slide per page. 

o Handouts – Prints the designated slides per page. (Printing 3 slides per page 

also prints lines for note taking to the right of the slides.) 

o Notes Pages – Prints one slide per page with the speaker notes on the bottom 

half of the page. 

o Outline View – Prints the outline of the presentation without pictures. 

 In the Page Setup group, click on the Orientation button and choose Portrait or 

Landscape. 

 In the Preview group, click on the Next Page button or the Previous Page button 

to view each of the pages to be printed. 

 In the Print group, click on the Options button and choose Scale to Fit Paper to 

fit the largest possible image of the slide on the paper. 

 In the Print group, click on the Options button and choose Frame Slides to place a wire 
frame around each slide as a border. 

 In the Print group, click on the Print button. 

 Check the settings in the window and change them if desired. 

 Click on OK. 

Saving as PDF 

 To save or export a file to PDF, you must first install the Save as PDF add-in from the Microsoft Office 

website. 

o Go to http://www.microsoft.com  

o Type PDF in the search box located in the upper right corner. 

o Click on the result that says: Download details: 2007 Microsoft Office Add-in:… 

o Click on the Continue button next to “Validation required.” 

o After your computer has been validated, click on the Download button. 

o Click on Run. 

o Click on Run. 

o Check the box to Accept the Microsoft Software License Terms. 

o Click on Continue. 

o Click on OK. 

 Once the PDF add-in has been installed to the computer, open the 

document that needs to be converted to PDF. 

 Click on the Microsoft Office Button, place the cursor over Save 

As…, and click on PDF. 

 Navigate to the location where the PDF document will be saved. 

  (Optional) Type in a file name.  

 Click on the Options button.  

 Make choices in the Options window to determine what part of the 

presentation will be included in the pdf. 

 Click on OK and then click on Save. 

http://www.microsoft.com/
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Templates 
 Templates provide the basic format of a document. 

 Click on the Microsoft Office Button and then 

click on New. 

 The Templates section displays templates 

available on the computer. 

o Choose the category of template desired. 

o Click on the desired template. 

o Click on the Create button. 

 The Microsoft Office Online section connects to 

templates available online from Microsoft. 

o Choose a category and click on the 
desired template. 

o Click on the Download button. 

o The template opens in PowerPoint. 

o Note – The document should be saved to 

the computer. 

 
 


